Bug 381

: UnsatisfiedLinkError using Windows AMD 64 DLLs
: [JogAmp] Jogl : Sven Gothel <sgothel>
: windows: Sven Gothel <sgothel>
: VERIFIED FIXED    
: critical    
: P2    
: 1   
: pc_x86_64   
: windows   
Type: --- SCM Refs:
Workaround: ---

Description Sven Gothel 2010-03-24 08:04:13 CET


---- Reported by sgothel@jausoft.com 2010-03-22 12:45:06 -0400 ----




---- Reported by ebbert@kenai.com 2010-02-06 16:48:54 ----

I can't get the JOGL DLLs to work using Suns JRE 1.6 for 64bit systems, Windows XP 64 and the jogl-natives-windows-amd64. I am using all other natives (linux, linux 64, macosx, windows-i586) without any problems, but trying the 64bit windows DLLs I get the following Exception:

                java.lang.UnsatisfiedLinkError: D:\jogldlls\jogl.dll:
                This application has failed to start because the application configuration is
                incorrect. Reinstalling the application may fix this problem
                at java.lang.ClassLoader$NativeLibrary.load(Native Method)
                at java.lang.ClassLoader.loadLibrary0(Unknown Source)
                at java.lang.ClassLoader.loadLibrary(Unknown Source)
                at java.lang.Runtime.loadLibrary0(Unknown Source)
                at java.lang.System.loadLibrary(Unknown Source)
                at
                com.sun.opengl.impl.NativeLibLoader.loadLibraryInternal(NativeLibLoader.java:189)
                at com.sun.opengl.impl.NativeLibLoader.access$000(NativeLibLoader.java:49)
                at
                com.sun.opengl.impl.NativeLibLoader$DefaultAction.loadLibrary(NativeLibLoader.java:80)
                at
                com.sun.opengl.impl.NativeLibLoader.loadLibrary(NativeLibLoader.java:103)
                at com.sun.opengl.impl.NativeLibLoader.access$200(NativeLibLoader.java:49)
                at com.sun.opengl.impl.NativeLibLoader$1.run(NativeLibLoader.java:111)
                at java.security.AccessController.doPrivileged(Native Method)
                at com.sun.opengl.impl.NativeLibLoader.loadCore(NativeLibLoader.java:109)
                at
                com.sun.opengl.impl.windows.WindowsGLDrawableFactory.<clinit>(WindowsGLDrawableFactory.java:60)
                at java.lang.Class.forName0(Native Method)
                at java.lang.Class.forName(Unknown Source)
                at
                javax.media.opengl.GLDrawableFactory.getFactory(GLDrawableFactory.java:106)
                at
                javax.media.opengl.GLCanvas.chooseGraphicsConfiguration(GLCanvas.java:520)
                at javax.media.opengl.GLCanvas.<init>(GLCanvas.java:131)
            at javax.media.opengl.GLCanvas.<init>(GLCanvas.java:90)



--- Bug imported by sgothel@jausoft.com 2010-03-22 12:45 EDT  ---

This bug was previously known as _bug_ 2095 at http://kenai.com/bugzilla/show_bug.cgi?id=2095

The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here: sgothel@jausoft.com.
   Previous reporter was ebbert@kenai.com.





--- Bug imported by sgothel@jausoft.com 2010-03-24 08:04 EDT  ---

This bug was previously known as _bug_ 6 at http://jogamp.org/bugzilla/show_bug.cgi?id=6
Comment 2 Sven Gothel 2010-07-06 06:02:03 CEST
*** Bug 371 has been marked as a duplicate of this bug. ***