Bug 41

: WindowsOffscreenGLContext failed to create with "Unable to set pixel format"
: [JogAmp] Jogl : Sven Gothel <sgothel>
: core: Sven Gothel <sgothel>
: VERIFIED FIXED    
: normal    
: P3    
: 1   
: All   
: windows   
Type: DEFECT SCM Refs:
Workaround: ---

Description Sven Gothel 2010-03-24 07:45:53 CET


---- Reported by yvg 2003-09-14 08:27:19 ----

When trying to create off-screen context in Windows, it fails with  "Unable to set 
pixel format" exception.

DRAWABLE GL IS: net.java.games.jogl.impl.windows.WindowsGLImpl
DRAWABLE GLU IS: net.java.games.jogl.impl.GLUImpl
net.java.games.jogl.GLException: Unable to set pixel format
	at 
net.java.games.jogl.impl.windows.WindowsGLContext.choosePixelFormatAndCreateC
ontext(WindowsGLContext.java:286)
	at net.java.games.jogl.impl.windows.WindowsOffscreenGLContext.create
(WindowsOffscreenGLContext.java:157)
	at net.java.games.jogl.impl.windows.WindowsGLContext.makeCurrent
(WindowsGLContext.java:117)
	at 
net.java.games.jogl.impl.windows.WindowsOffscreenGLContext.makeCurrent
(WindowsOffscreenGLContext.java:116)
	at net.java.games.jogl.impl.GLContext.invokeGL(GLContext.java:162)
	at net.java.games.jogl.GLJPanel.reshape(GLJPanel.java:131)
	at java.awt.Component.setBounds(Component.java:1664)
	at java.awt.BorderLayout.layoutContainer(BorderLayout.java:691)
	at java.awt.Container.layout(Container.java:1020)
	at java.awt.Container.doLayout(Container.java:1010)
	at java.awt.Container.validateTree(Container.java:1092)
	at java.awt.Container.validate(Container.java:1067)
	at java.awt.Window.show(Window.java:461)
	at demos.jgears.JGears.main(JGears.java:35)

Machine configuration is:
WinXP
GeForce 440 Go
JDK 1.4.2

Yuri



---- Additional Comments From kbr 2005-01-31 01:37:38 ----

This is probably due to JOGL trying to request a double-buffered pixel format
for the offscreen surface. To prevent applications from having to explicitly set
the DoubleBuffered property of the GLCapabilities to false, the GLCanvas now
clones the incoming GLCapabilities and disables double-buffering before
requesting the underlying GLContext.




---- Additional Comments From kbr 2005-01-31 01:39:05 ----

*** Issue 129 has been marked as a duplicate of this issue. ***



--- Bug imported by sgothel@jausoft.com 2010-03-24 07:45 EDT  ---

This bug was previously known as _bug_ 41 at https://jogl.dev.java.net/bugs/show_bug.cgi?id=41

Unknown bug field "has_duplicates" encountered while moving bug
   <has_duplicates>
     <bug_id>129</bug_id>
     <who>kbr</who>
     <when>2005-01-31 01:39:05</when>
</has_duplicates>