Bug 568

: VirtualBox: Freeze on tests execution (build from sources)
: [JogAmp] Jogl : Misio-it <misio.it>
: core: Sven Gothel <sgothel>
: RESOLVED DUPLICATE    
: minor : sgothel
: ---    
: 2   
: pc_x86_64   
: windows   
Type: --- SCM Refs:
Workaround: ---

Description Misio-it 2012-03-19 21:33:35 CET
Host: CPU Intel Core i5 64bit; GPU Intel HD Graphics; OS Windows 7 64bit
Guest: VirtualBox 2 CPU; OS Archlinux (Release 2011.08.19; Kernel 3.0.3) with 1.4 Mesa 8.0.1

running "bash scripts/tests-x32.sh" in "jogl/make" directory produces:

GLUEGEN BUILDDIR: ../../gluegen/make/../build
JOGL DIR: ../build/..
JOGL BUILDDIR: ../build
JOGL BUILDDIR BASE: build
JOGL PROFILE: JOGL_ALL
Linux vbox 3.2.11-1-ARCH #1 SMP PREEMPT Thu Mar 15 09:16:03 UTC 2012 i686 Intel (R) Core(TM) i5-2410M CPU @ 2.30GHz GenuineIntel GNU/Linux
Info: NO JOGL SWT ../build/../make/lib/swt/gtk-linux-i686/swt-debug.jar
Info: NO Users SWT /home/user/.java/swt.jar
JOGAMP_ALL_AWT_CLASSPATH: .:../../gluegen/make/../build/gluegen-rt.jar:../build/jar/jogl.all.jar:../build/jar/jogl.test.jar::../../gluegen/make/../make/lib/junit.jar:/usr/share/java/apache-ant/bin/ant/lib/ant.jar:/usr/share/java/apache-ant/bin/ant/lib/ant-junit.jar
JOGAMP_ALL_NOAWT_CLASSPATH: .:../../gluegen/make/../build/gluegen-rt.jar:../build/jar/jogl.all.jar:../build/jar/jogl.test.jar::../../gluegen/make/../make/lib/junit.jar:/usr/share/java/apache-ant/bin/ant/lib/ant.jar:/usr/share/java/apache-ant/bin/ant/lib/ant-junit.jar
JOGAMP_MOBILE_CLASSPATH: .:../../gluegen/make/../build/gluegen-rt.jar:../build/jar/jogl.all.jar:../build/jar/jogl.test.jar::../../gluegen/make/../make/lib/junit.jar:/usr/share/java/apache-ant/bin/ant/lib/ant.jar:/usr/share/java/apache-ant/bin/ant/lib/ant-junit.jar
CLASSPATH: .:../../gluegen/make/../build/gluegen-rt.jar:../build/jar/jogl.all.jar:../build/jar/jogl.test.jar::../../gluegen/make/../make/lib/junit.jar:/usr/share/java/apache-ant/bin/ant/lib/ant.jar:/usr/share/java/apache-ant/bin/ant/lib/ant-junit.jar

MacOSX REMEMBER to add the JVM arguments -XstartOnFirstThread -Djava.awt.headless=true for running demos without AWT, e.g. NEWT
MacOSX REMEMBER to add the JVM arguments -XstartOnFirstThread -Djava.awt.headless=true com.jogamp.newt.util.MainThread for running demos with NEWT
/usr/bin/java
java version "1.7.0_03-icedtea"
OpenJDK Runtime Environment (IcedTea7 2.1) (ArchLinux build 7.b147_2.1-3-i686)
OpenJDK Client VM (build 22.0-b10, mixed mode)
LIBXCB_ALLOW_SLOPPY_LOCK:
LIBGL_DRIVERS_PATH:
LIBGL_DEBUG:
SWT_CLASSPATH:
/usr/bin/java -d32
MacOsX 0
CLASSPATH .:../../gluegen/make/../build/gluegen-rt.jar:../build/jar/jogl.all.jar:../build/jar/jogl.test.jar::../../gluegen/make/../make/lib/junit.jar:/usr/share/java/apache-ant/bin/ant/lib/ant.jar:/usr/share/java/apache-ant/bin/ant/lib/ant-junit.jar
CLASSPATH .:../../gluegen/make/../build/gluegen-rt.jar:../build/jar/jogl.all.jar:../build/jar/jogl.test.jar::../../gluegen/make/../make/lib/junit.jar:/usr/share/java/apache-ant/bin/ant/lib/ant.jar:/usr/share/java/apache-ant/bin/ant/lib/ant-junit.jar

Test Start: com.jogamp.opengl.test.junit.jogl.acore.TestAWTCloseX11DisplayBug565

LD_LIBRARY_PATH /home/user/GNUstep/Library/Libraries:/usr/lib

/usr/bin/java -d32 -Djava.awt.headless=false com.jogamp.opengl.test.junit.jogl.acore.TestAWTCloseX11DisplayBug565
JUnit version 4.8.2
.Info: XInitThreads() called for concurrent Thread support
OpenGL Warning: glXChooseVisual: ignoring attribute 0x23
OpenGL Warning: XGetVisualInfo returned 0 visuals for (nil)

... Freezed!

Please take into account that even if the build succeeded (no errors reported), I am still not sure that everything went good; I am used to use the described virtualbox to do any sort of tests or stub development.
Comment 1 Sven Gothel 2012-03-25 05:58:02 CEST
I assume it freezes within glXMake[Context]Current* while on the AWT EDT ?
If so, it's a duplicate of bug 566

Pls check while using 'jstack -l <PID>'

Remedy .. well:
  - Install a bug-free Mesa8 binary (self compile .. or ..)
  - set property "-Dsun.java2d.opengl=True"
Comment 2 Sven Gothel 2012-03-25 14:53:08 CEST
VBox 4.1.8 
- Linux/Debian host
- Linux/ArchLinux guest 
  - Mesa3D 8.0.2 (pacman) Software

GL_VENDOR: VMware, Inc.
GL_RENDERER: Gallium 0.4 on llvmpipe (LLVM 0x300)
GL_VERSION: 2.1 Mesa 8.0.2

No freeze ..
Comment 3 Sven Gothel 2012-03-25 14:53:52 CEST
see comment #1

*** This bug has been marked as a duplicate of bug 566 ***