Bug 689

: App works from command line, but does not work from JNLP
: [JogAmp] Jogl : Anthony Ananich <anton.ananich>
: windows: Sven Gothel <sgothel>
: RESOLVED FIXED    
: normal    
: ---    
: 2   
: pc_x86_32   
: windows   
Type: --- SCM Refs:
Workaround: ---

Description Anthony Ananich 2013-02-12 17:04:39 CET
I used this tutorial and made OneTriangle app
http://jogamp.org/wiki/index.php/Using_JOGL_in_Java_Web_Start

It runs fine in many environments except one computer with Intel Atom CPU D525 1.80GHz. CPU Specification:
http://ark.intel.com/products/49490/Intel-Atom-processor-D525-1M-Cache-1_80-GHz

There are no errors in Java Console.

Expected Behaviour: Window with 3-color triangle and black background.

Actual Behaviour: A window with transparent background without the triangle. Looks like drawing surface is not initialized.

I tried to launch the app from command line in the same environment and it works like a charm. The bug can only be reproduced when app is launched from Java WebStart.
Comment 1 Sven Gothel 2013-02-16 04:15:36 CET
Please provide platform, .. , debug info (wiki/faq/bug report).

You can generate debug info for JNLP via the property settings
as described here http://jogamp.org/wiki/index.php/Jogl_FAQ#Applets_and_Java_Webstart

~Sven
Comment 2 Sven Gothel 2013-02-16 04:16:31 CET
reduced to 'normal' since it is not confirmed yet ..

btw - can you pls also test w/ one of our latest pre-releases ?

http://jogamp.org/deployment/archive/master/gluegen_629-joal_396-jogl_903-jocl_741-signed/

thank you
Comment 3 Anthony Ananich 2013-02-16 13:58:56 CET
Hi, Sven.

I tested the same app in the same computer using this build

> http://jogamp.org/deployment/archive/master/gluegen_629-joal_396-jogl_903-jocl_741-signed/

... and it works for me! Thank you very much for your help!