Bug 744

: RLE encoded tga images support
: [JogAmp] Jogl : Petr Skramovsky <petr.skramovsky>
: opengl: Petr Skramovsky <petr.skramovsky>
: RESOLVED FIXED    
: enhancement : sgothel
: ---    
: 2   
: All   
: all   
Type: --- SCM Refs:
4bfeef1c298e6861c0a607811edc9bef88d6084b
Workaround: ---
Attachments: example

Description Petr Skramovsky 2013-06-04 02:30:44 CEST
Created attachment 471 [details]
example

com.jogamp.opengl.util.texture.spi.TGAImage.java missing support of RLE encoded images ie attached image
Comment 1 Petr Skramovsky 2013-06-04 02:33:37 CEST
Possible fix/improvement https://github.com/petr-s/jogl/commit/8295953be23408f19751a178a0d8ac8cf9b8a17c
TODOs are for discussion
Comment 2 Sven Gothel 2013-06-15 01:54:45 CEST
Petr, I have assign this bug to you now, since you seem to not only have an interest
in this feature - but are also capable to do so.

Pls check my JOGL commit fixing Bug 745 as a 'quality' reference 
http://jogamp.org/git/?p=jogl.git;a=commit;h=a83aea49479818a1e5037d11a3e7f7d1f019c939

- fix
- unit test (i.e. w/ your test picture .. etc)

Would be great .. pull request etc.

Thank you!
Comment 3 Sven Gothel 2013-07-17 04:34:36 CEST
.. any progress ?
Comment 4 Petr Skramovsky 2013-07-17 15:52:00 CEST
I'm sorry, i was kinda busy and completely forget about this bug..., so here's https://github.com/petr-s/jogl/commit/4bfeef1c298e6861c0a607811edc9bef88d6084b the patch/fix + junit test but still i'm not so happy about naming/structure and overall design of the class... feel free to discuss...
Comment 5 Sven Gothel 2014-01-09 18:29:21 CET
4bfeef1c298e6861c0a607811edc9bef88d6084b

commit 4bfeef1c298e6861c0a607811edc9bef88d6084b
Author: Petr Skramovsky <petr.skramovsky@gmail.com>
Date:   Wed Jul 17 13:36:33 2013 +0200

    Fix Bug 744: Added support of RLE encoded .tga