Bug 1094 - 2.2.1 Regression: temporary directory now crashes in applet
Summary: 2.2.1 Regression: temporary directory now crashes in applet
Status: RESOLVED DUPLICATE of bug 1067
Alias: None
Product: Jogl
Classification: JogAmp
Component: applet (show other bugs)
Version: 2
Hardware: pc_x86_64 windows
: --- normal
Assignee: Sven Gothel
URL:
Depends on:
Blocks:
 
Reported: 2014-10-10 14:06 CEST by Rene
Modified: 2014-10-10 15:10 CEST (History)
0 users

See Also:
Type: ---
SCM Refs:
Workaround: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rene 2014-10-10 14:06:33 CEST

    
Comment 1 Rene 2014-10-10 14:10:41 CEST
When loading an applet it will crash and say it's unable to determine a temporary directory with 2.2.1 but rolling back to 2.2.0 it behaves fine.

It even happens for me on the gears demo:
http://jogamp.org/deployment/jogamp-current/jogl-demos/jogl-newt-applet-runner-gears.html

Likely to be affected by the fix for: https://jogamp.org/bugzilla/show_bug.cgi?id=1015

Running in chrome on windows 7 + Java 7.
Comment 2 Rene 2014-10-10 14:11:07 CEST
Stack trace:
Warning: Caught Exception while retrieving executable temp base directory:
java.lang.RuntimeException: Could not determine a temporary directory
	at com.jogamp.common.util.IOUtil.getTempDir(IOUtil.java:1388)
	at com.jogamp.common.util.cache.TempFileCache.<clinit>(TempFileCache.java:80)
	at com.jogamp.common.util.cache.TempJarCache.initSingleton(TempJarCache.java:89)
	at com.jogamp.common.os.Platform$1.run(Platform.java:201)
	at java.security.AccessController.doPrivileged(Native Method)
	at com.jogamp.common.os.Platform.<clinit>(Platform.java:179)
	at javax.media.opengl.GLProfile.<clinit>(GLProfile.java:120)
	at com.jogamp.newt.awt.applet.JOGLNewtApplet1Run.init(JOGLNewtApplet1Run.java:182)
	at com.sun.deploy.uitoolkit.impl.awt.AWTAppletAdapter.init(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
java.lang.RuntimeException: java.lang.UnsatisfiedLinkError: Can't load library: C:\Program Files (x86)\Google\Chrome\Application\37.0.2062.124\gluegen-rt.dll
	at com.jogamp.newt.awt.applet.JOGLNewtApplet1Run.init(JOGLNewtApplet1Run.java:228)
	at com.sun.deploy.uitoolkit.impl.awt.AWTAppletAdapter.init(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.UnsatisfiedLinkError: Can't load library: C:\Program Files (x86)\Google\Chrome\Application\37.0.2062.124\gluegen-rt.dll
	at java.lang.ClassLoader.loadLibrary(Unknown Source)
	at java.lang.Runtime.load0(Unknown Source)
	at java.lang.System.load(Unknown Source)
	at com.jogamp.common.jvm.JNILibLoaderBase.loadLibraryInternal(JNILibLoaderBase.java:596)
	at com.jogamp.common.jvm.JNILibLoaderBase.access$000(JNILibLoaderBase.java:64)
	at com.jogamp.common.jvm.JNILibLoaderBase$DefaultAction.loadLibrary(JNILibLoaderBase.java:96)
	at com.jogamp.common.jvm.JNILibLoaderBase.loadLibrary(JNILibLoaderBase.java:459)
	at com.jogamp.common.os.DynamicLibraryBundle$GlueJNILibLoader.loadLibrary(DynamicLibraryBundle.java:388)
	at com.jogamp.common.os.Platform$1.run(Platform.java:209)
	at java.security.AccessController.doPrivileged(Native Method)
	at com.jogamp.common.os.Platform.<clinit>(Platform.java:179)
	at javax.media.opengl.GLProfile.<clinit>(GLProfile.java:120)
	at com.jogamp.newt.awt.applet.JOGLNewtApplet1Run.init(JOGLNewtApplet1Run.java:182)
	... 3 more
Comment 3 Sven Gothel 2014-10-10 14:34:09 CEST
Has been fixed in 2.2.2:
  http://jogamp.org/deployment/archive/rc/v2.2.2/
  https://jogamp.org/wiki/index.php/SW_Tracking_Report_Objectives_for_the_release_2.2.0

Bug 1067
  https://jogamp.org/bugzilla/show_bug.cgi?id=1067

Probably today, 2.2.4 will be released.

*** This bug has been marked as a duplicate of bug 1067 ***
Comment 4 Rene 2014-10-10 15:10:11 CEST
Verified to be fixed in 2.2.2.