Bug 1209 - Regression of Bug 1188 Patches: Parented Fullscreen Issues (X11, Windows)
: Regression of Bug 1188 Patches: Parented Fullscreen Issues (X11, Windows)
Status: RESOLVED FIXED
: None
: Newt
: JogAmp
: core (show other bugs)
: 2.3.2
: All all
: --- major
: Sven Gothel
:
: 1188
:
  Show dependency treegraph
 
Reported: 2015-08-30 19:03 CEST by Sven Gothel
Modified: 2015-09-27 01:26 CEST (History)
0 users

:
Type: ---
SCM Refs:
552dd898add86f8bd745ab4cc1a9e755edd9926d
Workaround: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Gothel 2015-08-30 19:03:34 CEST
Issues reported w/ NewtCanvasAWT Applets
when toggling fullscreen on X11 and Windows - at least.

Fullscreen On From NEWT Child: May not have proper FS size [at start].
Fullscreen Off Back to NEWT Child: May still have FS size.
Comment 1 Sven Gothel 2015-08-30 19:10:35 CEST
Can easily be reproduced with
  <com.jogamp.opengl.test.junit.jogl.demos.es2.newt.TestGearsES2NewtCanvasAWT>
Comment 2 Sven Gothel 2015-08-31 08:46:35 CEST
552dd898add86f8bd745ab4cc1a9e755edd9926d

    Fix Bug 1209 - Regression of Bug 1188 Patches: Parented Fullscreen Issues (X11, Windows)
    
    The regression was caused by WindowImpl changes:
      (1) Not ignoring maximizedChanged(..) during fullscreen.
          X11 windows may promote maximized state, which will be passed
          in reconfigure -> non-fullscreen and hinders reseting the original size.
    
      (2) getReconfigureMask(..) was wrongly translated to state-mask,
          i.e. special handling of STATE_MASK_UNDECORATED and STATE_MASK_CHILDWIN
          was removed.
    
    - Issues above were corrected
    
    - Replace PSTATE_MASK_FULLSCREEN_NFS* w/ own stateMaskNFS for simplification