Bug 385

: Apparently unnecessary catch(Throwable)s
: [JogAmp] Jogl : Sven Gothel <sgothel>
: core: Sven Gothel <sgothel>
: VERIFIED DUPLICATE    
: minor    
: P5    
: 1   
: All   
: all   
Type: --- SCM Refs:
Workaround: ---
Bug :    
Bug : 395, 396    

Description Sven Gothel 2010-03-24 08:04:16 CET


---- Reported by sgothel@jausoft.com 2010-03-22 12:46:25 -0400 ----




---- Reported by redlizard@kenai.com 2010-03-10 22:36:03 ----

At several places in the source, catch(Throwable) is used for no reason that I've been able to uncover. This, of course, has the nasty effect of hiding certain severe errors that should normally abort the VM (and dump a stacktrace) immediately - in my case, a NoClassDefFoundError due to a filename typo somewhere, but most Errors qualify for this treatment.

            Is there a good reason all Throwables are often caught instead of only Exceptions? If not, it should probably be replaced by more debugging-friendly error checking.



--- Bug imported by sgothel@jausoft.com 2010-03-22 12:46 EDT  ---

This bug was previously known as _bug_ 2202 at http://kenai.com/bugzilla/show_bug.cgi?id=2202

Unknown platform all. Setting to default platform "".
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here: sgothel@jausoft.com.
   Previous reporter was redlizard@kenai.com.





--- Bug imported by sgothel@jausoft.com 2010-03-24 08:04 EDT  ---

This bug was previously known as _bug_ 10 at http://jogamp.org/bugzilla/show_bug.cgi?id=10

Unknown platform unknown. Setting to default platform "".

Comment 1 Sven Gothel 2010-03-24 08:13:14 CET
fix platform and os.
Comment 2 Sven Gothel 2010-07-06 06:14:47 CEST
Fixed by various code reviews listed at bug #395

*** This bug has been marked as a duplicate of bug 395 ***