Bug 1014 - support for mips/mipsel in gluegen2 version 2.1.5
Summary: support for mips/mipsel in gluegen2 version 2.1.5
Status: RESOLVED FIXED
Alias: None
Product: Gluegen
Classification: JogAmp
Component: core (show other bugs)
Version: 2
Hardware: Other linux
: --- enhancement
Assignee: Sven Gothel
URL:
Depends on: 1126
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-30 18:01 CEST by Dejan Latinovic
Modified: 2015-02-02 00:32 CET (History)
0 users

See Also:
Type: ---
SCM Refs:
Workaround: ---


Attachments
proposed patch for mips/mipsel support (7.83 KB, patch)
2014-05-30 18:01 CEST, Dejan Latinovic
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dejan Latinovic 2014-05-30 18:01:01 CEST
Created attachment 615 [details]
proposed patch for mips/mipsel support

Package sivp fails to build on Debian for mips/mipsel arch with an error:


CI_DISABLE_TK=1 SCI_JAVA_ENABLE_HEADLESS=1 DOCBOOK_ROOT=/usr/share/sgml/docbook/stylesheet/xsl/nwalsh \
/usr/bin/scilab -nw -f builder.sce
Could not create a Scilab main class. Error:
Exception in thread "main" java.lang.ExceptionInInitializerError
        at javax.media.opengl.GLProfile.<clinit>(GLProfile.java:83)
        at org.scilab.modules.gui.SwingView.<init>(Unknown Source)
        at org.scilab.modules.gui.SwingView.registerSwingView(Unknown Source)
        at org.scilab.modules.core.Scilab.<init>(Unknown Source)
Caused by: java.lang.RuntimeException: Please port CPU detection to your platform (linux/mipsel)
        at jogamp.common.os.PlatformPropsImpl.getCPUTypeImpl(PlatformPropsImpl.java:302)
        at jogamp.common.os.PlatformPropsImpl.<clinit>(PlatformPropsImpl.java:134)
        ... 4 more

Scilab cannot create Scilab Java Main-Class (we have not been able to find the main Scilab class. Check if the Scilab and thirdparty packages are available).
debian/rules:9: recipe for target 'build-arch' failed


The reason for this failure is a lack of support for mips/mipsel in Debian package gluegen2, version 2.1.5.

Patch add-mips-support.patch that contains support for mips/mipsel is attached.


After rebuilding gluegen2 with these changes, 
I was able to build sivp successfully.

Could you please consider including these changes into gluegen?


If you need any additional logs or info,
please contact me, I am willing to contribute.


Best Regards,
Dejan Latinovic
Comment 1 Sven Gothel 2015-02-02 00:32:54 CET
'Should' be fixed by changes for Bug 1126.

In case this (or a related) issue still persists,
please reopen this bug and comment.

Note: I don't have MIPS or MIPSLE hardware here.

Semantics of your changes however were added.