Bug 1121 - Wandboard IMX-6 not supported
Summary: Wandboard IMX-6 not supported
Status: RESOLVED DUPLICATE of bug 1062
Alias: None
Product: Jogl
Classification: JogAmp
Component: opengl (show other bugs)
Version: 2.4.0
Hardware: embedded_arm linux
: --- critical
Assignee: Sven Gothel
Depends on:
Reported: 2015-01-23 10:28 CET by Cédric Koch-Hofer
Modified: 2015-09-27 08:41 CEST (History)
2 users (show)

See Also:
SCM Refs:
Workaround: ---

Platform, OpenGL, JOGL, and runtime logs (26.46 KB, application/x-compressed)
2015-01-23 10:28 CET, Cédric Koch-Hofer

Note You need to log in before you can comment on or make changes to this bug.
Description Cédric Koch-Hofer 2015-01-23 10:28:48 CET
Created attachment 686 [details]
Platform, OpenGL, JOGL, and runtime logs


I am trying to use JOGL with a Wandboard IMX-6 platform.
However, the test.sh and test_dbg.sh are crashing with this platform (logs in the tarball attached to this email). I tried to use different JDKs (OpenJDK-1.6 and OracleJDK-1.7) with similar results:

I have attached to this email all the information that could help. Following, is a resume of these informations.

Processor: ARMv7 Processor rev 10 (v7l) - 4 cores
Hardware: Wandboard
OpenGL vendor string: Vivante Corporation
OpenGL renderer string: GC2000 Graphics Engine
OpenGL version string: 2.1 2.0.1
OpenGL shading language version string: 1.20
OS: Ubuntu - 12.04.3 LTS, Precise Pangolin
JOGL version: 2.2.4
JOGL GIT branch: origin/b22x
JOGL GIT Commit: 78f641de80d1c37cd61e5300eeba369c6aa9b1a1

Any help will be appreciate,
Thanks in advance,
Cédric Koch-Hofer.
Comment 1 Julien Gouesse 2015-03-31 16:52:12 CEST

Is it reproducible with JOGL 2.3.1?
Comment 2 Xerxes Rånby 2015-09-27 08:36:39 CEST
I have looked through your log files,

your glxinfo.log reveal that you are using the Vivante "binary blob" GPU driver.
OpenGL vendor string: Vivante Corporation
OpenGL renderer string: GC2000 Graphics Engine
OpenGL version string: 2.1 2.0.1

your test_dbg logs indicate a crash in glGetString.
I strongly belive this bug is a duplicate of bug 1062.

The JogAmp team currently do not have a board with a Vivante GPU to test on.
It would be good if you can help triage this bug:

Can you try using 'etna_viv' open source driver?

In bug 1062 we would like to know if disable query of desktop libGL* may workaround this issue.
You can disable query of dektop libGL* by passing
java -Djogl.disable.opengldesktop
by doing so make JOGL only use libEGL* to initialize OpenGL ES

*** This bug has been marked as a duplicate of bug 1062 ***
Comment 3 Xerxes Rånby 2015-09-27 08:41:42 CEST
I forgot to say, it is good if you include the hotspot generated crash log
since it usually include a stack bracktrace.