Bug 1131 - Some TTF fonts not working in the new Graph API renderer
Summary: Some TTF fonts not working in the new Graph API renderer
Status: UNCONFIRMED
Alias: None
Product: Jogl
Classification: JogAmp
Component: graph (show other bugs)
Version: 2.4.0
Hardware: All all
: --- major
Assignee: Sven Gothel
URL:
Depends on:
Blocks: 1064
  Show dependency treegraph
 
Reported: 2015-02-23 15:54 CET by Alan Sambol
Modified: 2015-10-01 10:00 CEST (History)
3 users (show)

See Also:
Type: FEATURE
SCM Refs:
Workaround: ---


Attachments
Example of a problematic font (167.07 KB, application/octet-stream)
2015-02-23 15:55 CET, Alan Sambol
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Sambol 2015-02-23 15:54:31 CET
I downloaded the play fonts from here http://www.fontsquirrel.com/fonts/play in TTF format. 

The bold one works fine, but the regular one can't find any glyphs when trying to draw: 

 java.lang.RuntimeException: Could not retrieve glyph for symbol: <T> 84 -> glyph id 0 
        at jogamp.graph.font.typecast.TypecastFont.getGlyph(TypecastFont.java:200) 
        at com.jogamp.graph.curve.opengl.TextRegionUtil.processString(TextRegionUtil.java:123) 
        at com.jogamp.graph.curve.opengl.TextRegionUtil.addStringToRegion(TextRegionUtil.java:153) 
        at com.jogamp.graph.curve.opengl.TextRegionUtil.drawString3D(TextRegionUtil.java:182) 

This happens to most of TTF fonts I tried.
Comment 1 Alan Sambol 2015-02-23 15:55:19 CET
Created attachment 689 [details]
Example of a problematic font