Bug 1157 - AWTTextureIO does not create a Texture from a device-compatible BufferedImage
: AWTTextureIO does not create a Texture from a device-compatible BufferedImage
Status: RESOLVED DUPLICATE of bug 1226
: None
: Jogl
: JogAmp
: awt (show other bugs)
: 2.3.2
: All windows
: --- enhancement
: Sven Gothel
:
:
:
 
Reported: 2015-05-15 13:01 CEST by charismarangos
Modified: 2015-09-27 02:10 CEST (History)
2 users (show)

:
Type: ---
SCM Refs:
Workaround: ---


Attachments
test case (eclipse project with libs) (5.17 KB, application/x-zip-compressed)
2015-05-26 17:34 CEST, Stephen Ranger
Details
This a maven project created for Bug 1157 (33.84 KB, application/zip)
2015-07-08 13:57 CEST, Ali Can Albayrak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description charismarangos 2015-05-15 13:01:33 CEST
The error I get is:
Could not find PixelFormat for format and/or type: PixelAttributes[fmt 0x80e1, type 0x8367, null]

The same buffered image would work for versions prior to 2.3.x

Creating a texture before converting the BufferedImage to a device-compatible one seems to work fine for my machine.
Comment 1 Julien Gouesse 2015-05-26 14:41:28 CEST
Please provide a test case and an image to reproduce your bug.
Comment 2 Stephen Ranger 2015-05-26 17:34:41 CEST
Created attachment 696 [details]
test case (eclipse project with libs)

With the 2.3.0 jars, it fails to create a TextureRenderer object in Windows. (Also tested with 2.2.0 jars and worked correctly). 

Note: could not add jars into zip as it was too large for attaching to comment
Comment 3 Julien Gouesse 2015-07-07 16:54:09 CEST
TextureRendererTest uses TextureRenderer, how does it demonstrate anything?
Comment 4 Ali Can Albayrak 2015-07-08 13:57:34 CEST
Created attachment 703 [details]
This a maven project created for Bug 1157

I reproduce the problem and shared as a maven project. So, you can change level of jogl libraries and examine the issue.
Comment 5 Julien Gouesse 2015-07-08 16:08:59 CEST
(In reply to comment #4)
> Created attachment 703 [details]
> This a maven project created for Bug 1157
> 
> I reproduce the problem and shared as a maven project. So, you can change
> level of jogl libraries and examine the issue.

I have just looked at Bug1157_Test (in the "test/" directory), it's ok for me. I'll run it soon. Disabling the auto swap buffer mode isn't necessary.
Comment 6 Sven Gothel 2015-09-27 02:10:27 CEST
format GL_BGRA 0x80E1
type   GL_UNSIGNED_INT_8_8_8_8_REV

Hence this is a duplicate of Bug 1226

*** This bug has been marked as a duplicate of bug 1226 ***