Bug 1245 - glXCreateContextAttribsARB crashes w/ Java3D on JTabbedPane (OpenSUSE 13.2, Mesa 10.3.7, Intel Haswell Desktop)
: glXCreateContextAttribsARB crashes w/ Java3D on JTabbedPane (OpenSUSE 13.2, M...
Status: RESOLVED WORKSFORME
: None
: Jogl
: JogAmp
: awt (show other bugs)
: 2.3.2
: pc_all linux
: --- major
: Sven Gothel
:
:
: 1248
  Show dependency treegraph
 
Reported: 2015-10-03 23:43 CEST by Sven Gothel
Modified: 2015-10-09 03:17 CEST (History)
3 users (show)

:
Type: DEFECT
SCM Refs:
124e866c23c5eff007c24206450cf9cda5b361d5
Workaround: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Gothel 2015-10-03 23:43:03 CEST
GL_VENDOR      Intel Open Source Technology Center
GL_RENDERER    Mesa DRI Intel(R) Haswell Desktop
GL_VERSION     3.0 Mesa 10.3.7 

- OpenSUSE 13.2
- Mesa 10.3.7
- GPU: Intel Haswell Desktop
- CPU: amd64 (Intel)

Latest JOGL tested: 2.3.2-rc-20150925

+++

Stack: [0x00007f52333d4000,0x00007f52334d5000],  sp=0x00007f52334d30b0,  free space=1020k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C  [libGL.so.1+0x1d480]

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j  jogamp.opengl.x11.glx.GLXExtImpl.dispatch_glXCreateContextAttribsARB0(JJJZLjava/lang/Object;IJ)J+0
j  jogamp.opengl.x11.glx.GLXExtImpl.glXCreateContextAttribsARB(JJJZLjava/nio/IntBuffer;)J+75
j  jogamp.opengl.x11.glx.X11GLXContext.createContextARBImpl(JZIII)J+369
j  jogamp.opengl.GLContextImpl.createContextARB(JZ)J+333
j  jogamp.opengl.x11.glx.X11GLXContext.createImpl(J)Z+611
j  jogamp.opengl.GLContextImpl.makeCurrentWithinLock(I)I+224
j  jogamp.opengl.GLContextImpl.makeCurrent(Z)I+488
j  jogamp.opengl.GLContextImpl.makeCurrent()I+2
j  javax.media.j3d.JoglPipeline.createNewContext(Ljavax/media/j3d/Canvas3D;Ljavax/media/j3d/Drawable;Ljavax/media/j3d/Context;ZZ)Ljavax/media/j3d/Context;+167
j  javax.media.j3d.Canvas3D.createNewContext(Ljavax/media/j3d/Drawable;Ljavax/media/j3d/Context;ZZ)Ljavax/media/j3d/Context;+9
j  javax.media.j3d.Canvas3D.createNewContext(Ljavax/media/j3d/Context;Z)Ljavax/media/j3d/Context;+11
J 5008 C2 javax.media.j3d.Renderer.doWork(J)V (6213 bytes) @ 0x00007f52b9c90b2c [0x00007f52b9c8cfa0+0x3b8c]
j  javax.media.j3d.J3dThread.run()V+19
v  ~StubRoutines::call_stub
Comment 2 Sven Gothel 2015-10-03 23:47:49 CEST
@Original Reported:
Q 1: Am I right that the Java3D's Canvas3D is similar to our AWT GLCanvas?
I will attempt to put your simple test case into on of ours,
i.e. modified TestBug816JTabbedPanelVisibilityB849B878AWT,
and see whether a crash could be reproduced.

Q 2: Crash can only be reproduced on mentioned
platform, or others as well?
Please make this statement in bug report,
as well as continue this discussion there ..

+++

We don't have exact same machines setup here.

Debian 8, Mesa 10.3.2
Some Intel, dunno Haswell though ..
Comment 3 Sven Gothel 2015-10-04 01:32:38 CEST
commit 124e866c23c5eff007c24206450cf9cda5b361d5:

TestBug1245JTabbedPanelCrashAWT passed as expected on 
GNU/Linux, Debian8, amd64 w/:
- proprietary NV

- GL_RENDERER   = Gallium 0.4 on AMD ARUBA
  GL_VERSION    = 3.0 Mesa 10.3.2
  GL_VENDOR     = X.Org
Comment 4 Sven Gothel 2015-10-04 01:33:29 CEST
(In reply to Sven Gothel from comment #3)
> commit 124e866c23c5eff007c24206450cf9cda5b361d5:
> 
> TestBug1245JTabbedPanelCrashAWT passed as expected on 

Note: Test uses GLCanvas w/ GearsES2 and RedSquareES2, not Java3D.
Comment 5 Sven Gothel 2015-10-04 02:38:09 CEST
TestBug1245JTabbedPanelCrashAWT passed as expected on:

GL_RENDERER   = Mesa DRI Intel(R) Haswell Desktop 
GL_VERSION    = 3.0 Mesa 10.3.2
GL_VENDOR     = Intel Open Source Technology Center

Debian 8, amd64, Mesa 10.3.2,
GPU Intel HD4600 / Haswell

+++

Closing this bug now as WORKSFORME.

Please re-open this bug if you are able to reproduce 
this issue w/ the test TestBug1245JTabbedPanelCrashAWT,
you may even patch it a bit.
Please give more details for reproduction.
In case 2.3.2 has been delivered, please move it to version 2.4.0!

However, if the tests works fine, and the issue is Java3D
please file a new bug and make it depend on this one
for documentation.

Thank you!
Comment 6 andreas_hauffe 2015-10-05 08:12:44 CEST
I tried this on my platform and it is working without crashing. So I can confirm, it seems to be a Java3D problem.
Comment 7 Julien Gouesse 2015-10-05 10:00:41 CEST
(In reply to andreas_hauffe from comment #6)
> I tried this on my platform and it is working without crashing. So I can
> confirm, it seems to be a Java3D problem.

Your version of Mesa seems to be a little bit more recent than the one Sven used. Please can you run all unit tests?
Comment 8 Julien Gouesse 2015-10-05 10:04:08 CEST
(In reply to Sven Gothel from comment #2)
> @Original Reported:
> Q 1: Am I right that the Java3D's Canvas3D is similar to our AWT GLCanvas?
> I will attempt to put your simple test case into on of ours,
> i.e. modified TestBug816JTabbedPanelVisibilityB849B878AWT,
> and see whether a crash could be reproduced.
> 
Java3D canvases were designed to support multiple ways of accessing hardware acceleration, they use some (offscreen, onscreen) drawables under the hood but they don't extend our canvases.
Comment 9 andreas_hauffe 2015-10-05 15:05:42 CEST
(In reply to Julien Gouesse from comment #7)
> (In reply to andreas_hauffe from comment #6)
> > I tried this on my platform and it is working without crashing. So I can
> > confirm, it seems to be a Java3D problem.
> 
> Your version of Mesa seems to be a little bit more recent than the one Sven
> used. Please can you run all unit tests?

I followed http://jogamp.org/jogl/doc/HowToBuild.html and ran all unit tests. Seems to be ok. The results can be found here:
http://update.elamx.de/jogl-2.3-bmanual-20151005-linux-amd64-test-results-local.7z

Andreas