Bug 1315 - Broadcom VC IV overlay when windowed does not take HDMI overscan setting into account
: Broadcom VC IV overlay when windowed does not take HDMI overscan setting into...
Status: RESOLVED FIXED
: None
: Jogl
: JogAmp
: embedded (show other bugs)
: 2.4.0
: embedded_arm linux
: P4 normal
: Sven Gothel
:
:
:
 
Reported: 2016-07-02 13:04 CEST by Gottfried Haider
Modified: 2019-03-27 03:56 CET (History)
1 user (show)

:
Type: FEATURE
SCM Refs:
jogl 51d301875a65f511b6a9846fc3bf661e50a48a68
Workaround: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gottfried Haider 2016-07-02 13:04:54 CEST
By default, the Raspberry Pi firmware applies an overscan setting for connected HDMI displays (which can manually disabled by setting disable_overscan=1 in the config.txt).

When overscan is enabled, the size of the desktop is reduced by a number of pixels. So for example, on a 1280x720 display, with overscan enabled, running "fbset -s" will report a geometry of only 1184x624 pixels.

Now with Processing, when running a windowed sketch that uses the JOGL renderer, the overlayed GL surface is offset to the window decoration. I presume that is because the GL part is working with the native resolution of the display, while the X part is not.

I spotted this behavior with Raspbian Jessie version May 2016, and with the latest firmware of today. Disabling overscan fixes this artifact for me. I will check with older releases of the Raspbian distribution to see if this perhaps a regression on their side.

Please let me know if you think that this should be handled differently on Rasbpian's side - I can try to take it up with them. Thanks!
Comment 1 Sven Gothel 2019-03-27 03:56:20 CET
I have merged your patch.
Since I don't test this platform - I trust you here.

Please reopen this bug if required.