Bug 1353 - java.lang.UnsatisfiedLinkError for gluegen-rt.dll due to localized tempdir name
: java.lang.UnsatisfiedLinkError for gluegen-rt.dll due to localized tempdir name
Status: RESOLVED FIXED
: None
: Jogl
: JogAmp
: util (show other bugs)
: 2.4.0
: All windows
: P4 blocker
: Sven Gothel
:
: 1366
:
  Show dependency treegraph
 
Reported: 2017-03-30 15:29 CEST by Randolf Schultz
Modified: 2019-03-30 06:13 CET (History)
1 user (show)

:
Type: DEFECT
SCM Refs:
Workaround: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Randolf Schultz 2017-03-30 15:29:43 CEST
Greetings,

when we set the default locale of our application to "hindi" (on a non
hindi Windows), JOGL fails to load with
-snip-
Caused by: java.lang.UnsatisfiedLinkError: C:\Users\redacted\AppData\Local\Temp\jogamp_????\file_cache\jln233449649495440797\jln200071770090761889\gluegen-rt.dll: Can't find dependent libraries
-snap-

The ???? are localized numbers (in hindi) which some other part of
the system probably can not cope with.

Is changing
String.format("_%04d", i);
to
String.format(null, "_%04d", i);
in
java/com/jogamp/common/util/IOUtil.java/getSubTempDir()
a viable fix?

Note that since our build is now completely Maven based, we use JOGL 2.3.1,
so that we can not easily test the bug on current versions, but judging
from the current source code, we feel this problem persists...

regards,
Randolf
Comment 1 Julien Gouesse 2017-04-20 15:50:44 CEST
I don't understand why testing against JOGL 2.3.2 is difficult for you.

I'm not sure that your fix is viable as it would behave like no locale would be taken into account. I have to investigate.
Comment 2 Sven Gothel 2019-03-30 05:59:13 CET
Randolf, you probably found a good one. 
I have generalized the issue in Bug 1366 and a fix will be underway for version 2.4.0.
Thank you.
Comment 3 Sven Gothel 2019-03-30 06:13:15 CET
Fixed Bug 1366 

I close this one now. Please reopen if not fixing the issue at hand.