Bug 1382 - GNU/Linux AMD/Mesa Regression
: GNU/Linux AMD/Mesa Regression
Status: RESOLVED INVALID
: None
: Jogl
: JogAmp
: opengl (show other bugs)
: 2.4.0
: All linux
: P1 blocker
: Sven Gothel
:
:
: 1383
  Show dependency treegraph
 
Reported: 2019-08-20 07:09 CEST by Sven Gothel
Modified: 2019-08-20 19:45 CEST (History)
0 users

:
Type: DEFECT
SCM Refs:
Workaround: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Gothel 2019-08-20 07:09:58 CEST
GNU/Linux AMD GPU regression
-- 1) No compat profiles on X11 device
-- 2) Remaining core only profiles disclose buggy GLProfile selection
-- This needs to be fixed pre-release of 2.4.0

Effected:
- java11 tip
- gluegen_916-joal_642-jogl_1483-jocl_1122
- gluegen_913-joal_639-jogl_1477-jocl_1117

OK:
- gluegen_910-joal_636-jogl_1474-jocl_1112
- v2.3.2
  - jogl.build.number=1469

Regression injected ]1474-1477]

OK (last)
jogl.build.branch=origin/master
jogl.build.commit=347271ffdd09153a2334fda593774d49050f84e0
jogl.build.id=1474
jogl.build.number=1474
jogl.build.version=2.4.0-rc-20181210

Bug (first)
jogl.build.branch=origin/master
jogl.build.commit=ab10b11a9c94d9597f788e218fe45ede49c67f33
jogl.build.id=1477
jogl.build.number=1477
jogl.build.version=2.4.0-rc-20190406
Comment 1 Sven Gothel 2019-08-20 19:45:42 CEST
1) No compat profiles on X11 device

This is not a bug since 
compat profiles being disabled via GLRendererQuirks.GLNonCompliant
and GLProfile fails to use the highest core profile available as default.

Closing this one and moved (2) to Bug 1383