Bug 231 - cannot find symbol DebugGL
Summary: cannot find symbol DebugGL
Alias: None
Product: Jogl
Classification: JogAmp
Component: core (show other bugs)
Version: 1
Hardware: All linux
: P3 normal
Assignee: Sven Gothel
Depends on:
Reported: 2006-06-29 11:27 CEST by Sven Gothel
Modified: 2010-03-24 07:49 CET (History)
0 users

See Also:
SCM Refs:
Workaround: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Sven Gothel 2010-03-24 07:49:07 CET

---- Reported by nichoj 2006-06-29 11:27:37 ----

I just downloaded jogl-src-1_0_0-beta05.zip, and attempted to build it, but it
fails with:

    [javac] Compiling 179 source files to /home/jnichols/testing/jogl/build/classes
cannot find symbol
    [javac] symbol: class DebugGL
    [javac]                 j2dContext.setGL(new DebugGL(j2dContext.getGL()));
    [javac]                                      ^
cannot find symbol
    [javac] symbol: class DebugGL
    [javac]                     joglContext.setGL(new DebugGL(joglContext.getGL()));
    [javac]                                           ^
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
    [javac] 2 errors

/home/jnichols/testing/jogl/make/build.xml:1445: The following error occurred
while executing this line:
/home/jnichols/testing/jogl/make/build.xml:706: Compile failed; see the compiler
error output for details.

I did some poking around, and there doesn't seem to be a DebugGL.java kicking
around anywhere. I also tried a CVS checkout, but with the same results.

---- Additional Comments From kbr 2006-07-08 16:51:32 ----

I've just downloaded and built the beta 5 sources successfully. I suspect you
had a failed build, retried it from the middle of the build process, and the
build got confused. Please rebuild from scratch and post on the JOGL forum
rather than filing a bug if you have further problems.

---- Additional Comments From nichoj 2006-07-11 08:49:11 ----

I also did a fresh download and build attempt, to the same effect.
Like I mentioned, I also did a CVS checkout to the same effect.

---- Additional Comments From kbr 2006-07-11 08:53:04 ----

I'm sorry, but I can't reproduce this problem. Things I would suggest trying are:

 - Make sure you are using a current version of Ant
 - Make sure you are using a current version of ANTLR
 - Unset your CLASSPATH and JAVA_HOME environment variables
 - Double-check to make sure the JDK's "bin" directory is in your PATH

Please post on the forums rather than reopening this bug if you still have
trouble; this way more people can see the issue.

---- Additional Comments From nichoj 2006-07-11 10:15:54 ----

Is DebugGL a class provided by jogl? Presumably since there isn't an import, I'd
figure it's in javax.media.opengl. I did a find for it, and there doesn't seem
to be a class or source for it...

Or does it come from another package / jar ?

The classpath is empty, and you can't unset JAVA_HOME, because it needs to point
to the JDK that you're currently using. As a side note, I've tried compiling
with Sun's 1.4, 1.5, and 1.6 JDK to the same effect.

I'm using ant 1.6.5, and antlr 2.7.5.

As for the forums, they seem to be dead / dying, with notices that they will
soon be deleted.

---- Additional Comments From kbr 2006-07-11 10:22:21 ----

I'll admit the location of the forums is a bit confusing, but the "live" forum's
link is on the right-hand side of the JOGL home page, and it's very much alive.
I've updated the forums in the JOGL project to have a direct link.

The DebugGL class is generated during the build process. I'm not sure if you're
trying to invoke the build from within an IDE or are doing it from the command
line but the latter is the only mechanism we currently support. I have heard
varying degrees of success from NetBeans and Eclipse users on invoking the
build.xml from within the IDE.

---- Additional Comments From nichoj 2006-07-11 10:43:17 ----

I'm executing ant from the command line. Ultimately, I'd be executing ant
noninteractively in order to package for Gentoo Linux.

I figured out what the problem was. I was trying to build from not inside the
'make' directory. After going in that directory, it seemed to get further along.

I'm having a separate issue now, but I guess the forums is the best place to
look for help.

--- Bug imported by sgothel@jausoft.com 2010-03-24 07:49 EDT  ---

This bug was previously known as _bug_ 231 at https://jogl.dev.java.net/bugs/show_bug.cgi?id=231