Bug 352 - distortion using TextRenderer (sometimes)
Summary: distortion using TextRenderer (sometimes)
Alias: None
Product: Jogl
Classification: JogAmp
Component: awt (show other bugs)
Version: 1
Hardware: All linux
: P5 normal
Assignee: Sven Gothel
Depends on:
Reported: 2008-03-30 05:51 CEST by Sven Gothel
Modified: 2012-01-23 00:09 CET (History)
0 users

See Also:
SCM Refs:
Workaround: ---

Test class (3.83 KB, text/plain)
2008-03-30 05:52 CEST, Sven Gothel
screenshot (5.20 KB, image/png)
2008-03-30 05:53 CEST, Sven Gothel

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Gothel 2010-03-24 07:51:24 CET

---- Reported by yug 2008-03-30 05:51:05 ----

Steps to reproduce: 
1) compile&run attached class bugs.TextDistortion
2) a black window containing the string "ARGH" should appear
3) press space (toggles redraw) until the G is distorted as shown in the
attached screenshot. 
I rarely have to press space more than 10 times to see the effect

OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9800 PRO
OpenGL version string: 2.1.7412 Release

---- Additional Comments From yug 2008-03-30 05:52:31 ----

Created an attachment
Test class

---- Additional Comments From yug 2008-03-30 05:53:12 ----

Created an attachment

---- Additional Comments From kbr 2008-03-30 15:10:14 ----

Unfortunately I can't reproduce this problem on my NVidia GeForce FX Go700
mobile hardware with the current graphics drivers.

It's going to be very difficult for us to fix this without being able to
reproduce it in house.

If you specify -Djogl.texture.notexrect on the command line when running your
test case, does it affect the behavior? This would indicate either a bug in the
TextRenderer in the case where the texture rectangle extensions are being used,
or a driver bug with the handling of said extensions.

---- Additional Comments From yug 2008-03-30 23:10:48 ----

Too bad you can't reproduce it :-(
No, -Djogl.texture.notexrect does not affect this behavior.

Problem still exists in driver version
OpenGL version string: 2.1.7536 Release

---- Additional Comments From yug 2008-03-31 01:17:35 ----

I am unable to reproduce it on:
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 865G 20061017 x86/MMX/SSE2
OpenGL version string: 1.3 Mesa 7.0.2

I guess it is a ati driver issue then. I will try to report it at

---- Additional Comments From yug 2008-03-31 02:04:42 ----


---- Additional Comments From kbr 2008-04-12 17:53:14 ----

Have you tried calling setUseVertexArrays(false) on the TextRenderer? We ran
into problems with Mac OS X machines with ATI hardware and that worked around
the issue.

---- Additional Comments From yug 2008-04-13 03:51:04 ----

Indeed, no distortion with setUseVertexArrays(false) ! Thanks for the hint!

Do you have a clue yet where the cause of this bug is hidden?
jogl? driver? hardware?

---- Additional Comments From yug 2008-04-13 04:05:47 ----

Bug does not occur either if I don't call setUseVertexArrays(false), but set

---- Additional Comments From kbr 2008-04-13 13:27:24 ----

I am pretty sure this is a bug in ATI's drivers. We have seen this problem with
ATI hardware on multiple operating systems but not with NVidia's hardware, again
on multiple operating systems.

--- Bug imported by sgothel@jausoft.com 2010-03-24 07:51 EDT  ---

This bug was previously known as _bug_ 352 at https://jogl.dev.java.net/bugs/show_bug.cgi?id=352
Imported an attachment (id=123)
Imported an attachment (id=124)

The original submitter of attachment 123 [details] is unknown.
   Reassigning to the person who moved it here: sgothel@jausoft.com.
The original submitter of attachment 124 [details] is unknown.
   Reassigning to the person who moved it here: sgothel@jausoft.com.