Bug 499 - Simple AWT and JOGL application hangs on startup
Summary: Simple AWT and JOGL application hangs on startup
Alias: None
Product: Jogl
Classification: JogAmp
Component: x11 (show other bugs)
Version: 2
Hardware: pc_x86_64 linux
: --- normal
Assignee: Sven Gothel
Depends on:
Reported: 2011-05-11 02:03 CEST by Mike Pleasance
Modified: 2011-08-30 22:26 CEST (History)
0 users

See Also:
Type: ---
SCM Refs:
Workaround: ---

Applcation output with jogl.debug=true (51.27 KB, text/plain)
2011-05-11 02:03 CEST, Mike Pleasance
Sample Code (1007 bytes, text/x-java)
2011-05-11 02:04 CEST, Mike Pleasance
SimpleScene V2 (2.17 KB, text/plain)
2011-08-30 22:23 CEST, Sven Gothel
SimpleScene V2 Log (4.86 KB, text/plain)
2011-08-30 22:24 CEST, Sven Gothel

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Pleasance 2011-05-11 02:03:55 CEST
Created attachment 254 [details]
Applcation output with jogl.debug=true

I am attempting to get a very basic JOGL application to run on Red Hat Enterprise 5.3.  The application creates a frame and adds a GLCanvas.

When the frame is set visible, the application hangs.

I tried adding the GLProfile.initSingleton(false) as mentioned in bug #494, but nothing changed.

I have attached the java code and the output when running with jogl.debug=true.

X-Windows and Linux information from xorg.0.log:

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.18-92.1.18.el5 x86_64 Red Hat, Inc.

If I debug in eclipse and break while the application has hung, I get the following stack trace:

GLX.dispatch_glXGetClientString1(long, int, long) line: not available [native method]	
GLX.glXGetClientString(long, int) line: 659	
GLXUtil.getExtension(long) line: 40	
GLXUtil.isMultisampleAvailable(long) line: 51	
X11GLXGraphicsConfigurationFactory.chooseGraphicsConfigurationFBConfig(GLCapabilitiesImmutable, GLCapabilitiesImmutable, GLCapabilitiesChooser, X11GraphicsScreen) line: 248	
X11GLXGraphicsConfigurationFactory.chooseGraphicsConfigurationStatic(GLCapabilitiesImmutable, GLCapabilitiesImmutable, GLCapabilitiesChooser, X11GraphicsScreen) line: 198	
X11GLXGraphicsConfigurationFactory.chooseGraphicsConfigurationImpl(CapabilitiesImmutable, CapabilitiesImmutable, CapabilitiesChooser, AbstractGraphicsScreen) line: 95	
X11GLXGraphicsConfigurationFactory(GraphicsConfigurationFactory).chooseGraphicsConfiguration(CapabilitiesImmutable, CapabilitiesImmutable, CapabilitiesChooser, AbstractGraphicsScreen) line: 240	
X11AWTGLXGraphicsConfigurationFactory.chooseGraphicsConfigurationImpl(CapabilitiesImmutable, CapabilitiesImmutable, CapabilitiesChooser, AbstractGraphicsScreen) line: 124	
X11AWTGLXGraphicsConfigurationFactory(GraphicsConfigurationFactory).chooseGraphicsConfiguration(CapabilitiesImmutable, CapabilitiesImmutable, CapabilitiesChooser, AbstractGraphicsScreen) line: 240	
GLCanvas.chooseGraphicsConfiguration(GLCapabilitiesImmutable, GLCapabilitiesImmutable, GLCapabilitiesChooser, GraphicsDevice) line: 978	
GLCanvas.addNotify() line: 517	
Frame(Container).addNotify() line: 2578	
Frame(Window).addNotify() line: 663	
Frame.addNotify() line: 470	
Frame(Window).show() line: 859	
Frame(Component).show(boolean) line: 1584	
Frame(Component).setVisible(boolean) line: 1536	
Frame(Window).setVisible(boolean) line: 842	
SimpleScene.main(String[]) line: 21	

I have tried the following versions of JOGL with the same results:

Please let me know if you require any additional information.
Comment 1 Mike Pleasance 2011-05-11 02:04:48 CEST
Created attachment 255 [details]
Sample Code
Comment 2 Sven Gothel 2011-08-30 22:23:49 CEST
Created attachment 263 [details]
SimpleScene V2

Change: Dumps version information, adds GLEventListener to check if called .. and closes Frame after 3d.
Comment 3 Sven Gothel 2011-08-30 22:24:18 CEST
Created attachment 264 [details]
SimpleScene V2 Log
Comment 4 Sven Gothel 2011-08-30 22:26:24 CEST
See attachment 263 [details] and it's log file attachment 264 [details].
It shows here that the SimpleScene is actually working on this platfrom (X11, 64bit, NV driver - but Ubuntu 11.04).

Sorry cannot reproduce, pls try w/ latest JOGL build, thank you.