Bug 762 - Too many users on the JogAmp Nabble forum; forum needs replacement
Summary: Too many users on the JogAmp Nabble forum; forum needs replacement
Status: RESOLVED DUPLICATE of bug 1095
Alias: None
Product: Default
Classification: Unclassified
Component: default (show other bugs)
Version: unspecified
Hardware: All all
: --- enhancement
Assignee: Sven Gothel
URL:
Depends on:
Blocks:
 
Reported: 2013-06-23 11:41 CEST by Xerxes Rånby
Modified: 2015-03-10 10:28 CET (History)
0 users

See Also:
Type: ---
SCM Refs:
Workaround: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xerxes Rånby 2013-06-23 11:41:39 CEST
The Nabble forum server are frequently overloaded:
Error 500' are now common: Oops... An error has occurred
Caused by: org.postgresql.util.PSQLException: FATAL: sorry, too many clients already
Test URL:
http://forum.jogamp.org/Java3D-crash-intel-4000-tp4029426.html

Output:
Error 500

url=http://forum.jogamp.org/Java3D-crash-intel-4000-tp4029426.html  method=GET user-agent=Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:21.0) Gecko/20100101 Firefox/21.0 referer=http://t.co/3YA6cHZKj4 remote=37.197.24.45

Message: key = 66646

RequestURI: /Java3D-crash-intel-4000-tp4029426.html

Server: n3.nabble.com
Caused by:

fschmidt.util.servlet.JtpContextServlet$JtpRuntimeException: url=http://forum.jogamp.org/Java3D-crash-intel-4000-tp4029426.html  method=GET user-agent=Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:21.0) Gecko/20100101 Firefox/21.0 referer=http://t.co/3YA6cHZKj4 remote=37.197.24.45
	at fschmidt.util.servlet.JtpContextServlet.handleException(JtpContextServlet.java:559)
	at fschmidt.util.servlet.JtpContextServlet.service2(JtpContextServlet.java:463)
	at fschmidt.util.servlet.JtpContextServlet.service(JtpContextServlet.java:332)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
	at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:565)
	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1360)
	at org.eclipse.jetty.servlets.UserAgentFilter.doFilter(UserAgentFilter.java:77)
	at org.eclipse.jetty.servlets.GzipFilter.doFilter(GzipFilter.java:144)
	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1331)
	at cachingfilter.CachingFilter.doFilter(CachingFilter.java:133)
	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1331)
	at fschmidt.util.servlet.BadBotFilter.doFilter(BadBotFilter.java:74)
	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1331)
	at fschmidt.util.servlet.ConnectionLimitFilter.doFilter(ConnectionLimitFilter.java:94)
	at nabble.view.lib.NabbleConnectionLimitFilter.doFilter(NabbleConnectionLimitFilter.java:26)
	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1331)
	at nabble.view.lib.NabbleErrorFilter.doFilter(NabbleErrorFilter.java:21)
	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1331)
	at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:477)
	at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:225)
	at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1031)
	at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:406)
	at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:186)
	at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:965)
	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117)
	at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:250)
	at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:149)
	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:111)
	at org.eclipse.jetty.server.Server.handle(Server.java:349)
	at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:449)
	at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:910)
	at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:634)
	at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:230)
	at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:76)
	at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:609)
	at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:45)
	at nabble.model.Executors$1$1.run(Executors.java:27)
	at fschmidt.util.executor.ThreadTimer$1.run(ThreadTimer.java:18)
	at fschmidt.util.executor.AbstractThreadPool$1.run(AbstractThreadPool.java:29)
	at java.lang.Thread.run(Thread.java:722)
Caused by: fschmidt.db.SQLRuntimeException: key = 66646
	at fschmidt.db.base.DbTableImpl.findByPrimaryKey(DbTableImpl.java:80)
	at fschmidt.db.cache.DbTableImpl.findByPrimaryKey(DbTableImpl.java:135)
	at nabble.model.UserImpl.getUser(UserImpl.java:402)
	at nabble.model.NodeImpl.getOwnerImpl(NodeImpl.java:1009)
	at nabble.model.NodeImpl.getOwner(NodeImpl.java:1015)
	at nabble.view.lib.NabbleErrorHandler.writeMyErrorPage(NabbleErrorHandler.java:78)
	at nabble.view.lib.NabbleErrorHandler.writeErrorPage(NabbleErrorHandler.java:51)
	at org.eclipse.jetty.server.handler.ErrorHandler.handleErrorPage(ErrorHandler.java:68)
	at org.eclipse.jetty.server.handler.ErrorHandler.handle(ErrorHandler.java:57)
	at nabble.view.lib.NabbleErrorHandler.handle(NabbleErrorHandler.java:31)
	at org.eclipse.jetty.server.Response.sendError(Response.java:331)
	at org.eclipse.jetty.server.Response.sendError(Response.java:399)
	at javax.servlet.http.HttpServletResponseWrapper.sendError(HttpServletResponseWrapper.java:128)
	at cachingfilter.CachingResponseWrapper.sendError(CachingResponseWrapper.java:322)
	at javax.servlet.http.HttpServletResponseWrapper.sendError(HttpServletResponseWrapper.java:128)
	at org.eclipse.jetty.http.gzip.GzipResponseWrapper.sendError(GzipResponseWrapper.java:296)
	at javax.servlet.http.HttpServletResponseWrapper.sendError(HttpServletResponseWrapper.java:128)
	at fschmidt.util.servlet.JtpContextServlet$5.sendError(JtpContextServlet.java:311)
	at javax.servlet.http.HttpServletResponseWrapper.sendError(HttpServletResponseWrapper.java:128)
	at nabble.view.web.forum.Permalink.sendToTopicPage(Permalink.java:111)
	at nabble.view.web.forum.Permalink.service(Permalink.java:102)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
	at fschmidt.util.servlet.JtpContextServlet.service2(JtpContextServlet.java:461)
	... 38 more
Caused by: org.postgresql.util.PSQLException: FATAL: sorry, too many clients already
	at org.postgresql.core.v3.ConnectionFactoryImpl.doAuthentication(ConnectionFactoryImpl.java:293)
	at org.postgresql.core.v3.ConnectionFactoryImpl.openConnectionImpl(ConnectionFactoryImpl.java:108)
	at org.postgresql.core.ConnectionFactory.openConnection(ConnectionFactory.java:66)
	at org.postgresql.jdbc2.AbstractJdbc2Connection.<init>(AbstractJdbc2Connection.java:125)
	at org.postgresql.jdbc3.AbstractJdbc3Connection.<init>(AbstractJdbc3Connection.java:30)
	at org.postgresql.jdbc3g.AbstractJdbc3gConnection.<init>(AbstractJdbc3gConnection.java:22)
	at org.postgresql.jdbc4.AbstractJdbc4Connection.<init>(AbstractJdbc4Connection.java:32)
	at org.postgresql.jdbc4.Jdbc4Connection.<init>(Jdbc4Connection.java:24)
	at org.postgresql.Driver.makeConnection(Driver.java:393)
	at org.postgresql.Driver.connect(Driver.java:267)
	at java.sql.DriverManager.getConnection(DriverManager.java:579)
	at java.sql.DriverManager.getConnection(DriverManager.java:190)
	at fschmidt.db.base.DbDatabaseImpl.getConnection(DbDatabaseImpl.java:67)
	at fschmidt.db.pool.PooledConnection.<init>(PooledConnection.java:68)
	at fschmidt.db.pool.Pool.getConnection2(Pool.java:149)
	at fschmidt.db.pool.Pool.getConnection(Pool.java:118)
	at fschmidt.db.pool.DbDatabaseImpl.getConnection(DbDatabaseImpl.java:132)
	at fschmidt.db.extend.FilterDatabase.getConnection(FilterDatabase.java:67)
	at fschmidt.db.base.DbTableImpl.findByPrimaryKey(DbTableImpl.java:65)
	... 60 more
Comment 1 Sven Gothel 2015-03-10 10:28:41 CET
Discussion continues on Bug 1095 ..

*** This bug has been marked as a duplicate of bug 1095 ***