Bug 864 - JOGL 2.1.1 does not work for GL3 on Mac OS X whereas 2.1.0 works
Summary: JOGL 2.1.1 does not work for GL3 on Mac OS X whereas 2.1.0 works
Status: RESOLVED DUPLICATE of bug 867
Alias: None
Product: Jogl
Classification: JogAmp
Component: macosx (show other bugs)
Version: 2
Hardware: All macosx
: P3 normal
Assignee: Sven Gothel
Depends on: 867
  Show dependency treegraph
Reported: 2013-10-22 17:58 CEST by ralph
Modified: 2013-10-23 17:55 CEST (History)
0 users

See Also:
Type: ---
SCM Refs:
Workaround: ---

Simple program showing the issue (5.36 KB, application/zip)
2013-10-23 09:36 CEST, ralph
Logs as requested (139.88 KB, application/zip)
2013-10-23 09:45 CEST, ralph

Note You need to log in before you can comment on or make changes to this bug.
Description ralph 2013-10-22 17:58:39 CEST
Even trivial programs using GL3 fail to work on a Mac in version 2.1.1, yet worked fine in 2.1.0.  I just get a blank window.

Even if the two lines say
  GL3 gl = d.getGL().getGL3(); // get the OpenGL 3 graphics context
  System.out.println(" GL_VERSION: "+ gl.glGetString(GL3.GL_VERSION) ); 
they fail to print anything out. 

Such code worked perfectly in jogl 2.1.0 and the program has not been changed.

This is on MacOS X 10.9, using Netbeans 7.4, for what its worth.

Code etc available on request.
Comment 1 Sven Gothel 2013-10-23 02:06:39 CEST
Set back to P3.normal, since it is:
  - not confirmed
  - bug report does not contain required details (Wiki/FAQ/bug..)
  - but not related to core JOGL, but NB ineroperability

Yes, pls post your 'most small' test case.

Besides posting the test_debug.log file (7z),
pls post the debug output of your test case 
w/ all debug properties enabled (7z) - w/ 2.1.1.

Maybe related to Bug 857 ?

Thank you.
Comment 2 ralph 2013-10-23 09:36:32 CEST
Created attachment 522 [details]
Simple program showing the issue
Comment 3 ralph 2013-10-23 09:45:11 CEST
Created attachment 523 [details]
Logs as requested
Comment 4 ralph 2013-10-23 09:48:18 CEST
(1) This is not a Netbeans issue. Running program standalone after compiling it displays the same behaviour. This IS a core JOGL issue.

(2) Test case now attached.

(3) Logs attached too. Looks like JOGL is looking in the wrong place for libraries.
Comment 5 Sven Gothel 2013-10-23 17:55:12 CEST
See bug 867
Comment 6 Sven Gothel 2013-10-23 17:55:56 CEST
Bug 867 describes the issue ..

*** This bug has been marked as a duplicate of bug 867 ***