Bug 1067 - IOUtil.testDirExec(File) needs to preserve SPACE in exetst.getCanonicalPath() command
Summary: IOUtil.testDirExec(File) needs to preserve SPACE in exetst.getCanonicalPath()...
Status: RESOLVED FIXED
Alias: None
Product: Gluegen
Classification: JogAmp
Component: core (show other bugs)
Version: 2
Hardware: All all
: --- major
Assignee: Sven Gothel
URL:
: 1094 (view as bug list)
Depends on:
Blocks: 1103 1109
  Show dependency treegraph
 
Reported: 2014-09-14 07:53 CEST by Sven Gothel
Modified: 2014-12-11 17:57 CET (History)
1 user (show)

See Also:
Type: ---
SCM Refs:
3a8515045c906b0174fb74f25b425f532b9cf2d1
Workaround: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Gothel 2014-09-14 07:53:13 CEST
Having a test-executable file with SPACE in it's temporary path,
e.g. 
  Unix:       /magic temp/user/
  Windows XP: C:\Documents and Settings\user\temp

results to split up commands if using
'Process.exec(String)', since it utilizes 
a StringTokenizer to assemble the command String[].

This patch uses 'Process.exec(String[])' avoiding 
splitting up SPACE in the full command string/path.

Major impact is on 'Windows XP',
where a SPACE separated TEMP/TMP folder is the default.

Note-1: Commit 9bc3d3f78bb2fb1aa0ccfb02ffb5bdda74420cac
introduced testing executable permission on Windows (Bug 1015)
and rendered this issue visible.

To reproduce the issue on Windows:
+++
set TEMP=C:\Documents and Settings\jogamp\temp
set TMP=C:\Documents and Settings\jogamp\temp
"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
+++

Note-2: This bug affects all platforms!
Comment 1 Sven Gothel 2014-09-14 07:55:40 CEST
3a8515045c906b0174fb74f25b425f532b9cf2d1
  Fixed as described
Comment 2 Sven Gothel 2014-10-10 14:34:09 CEST
*** Bug 1094 has been marked as a duplicate of this bug. ***